unIFY Control Panel
Overview and Application Features & Functions
The uniFY Control Panel software provides users with a simple tool to monitor and configure Attero Tech devices. It detects connected devices on the configured network automatically showing them in a device list. Once a device is discovered, uniFY can present further details about the device. For Attero Tech devices, uniFY is also used to configure the device settings such as gain and phantom power. This manual is designed to give the user a guide on how to use the Attero Tech uniFY Control Panel to monitor and configure Dante™ devices on a network.

Application Features

The uniFY application is at its heart a networked application. It can be run in a non-networked mode with very limited functionality if the only desired operation is to setup non-networked devices such as the BT2A. For full functionality, a network interface will need to be selected and that interface is then used for both device discovery and communication.

*Note: The BT2A can be configured in either networked mode as well as non-networked mode.

When uniFY is opened, it will check what network adaptor was previously selected and see if it is still valid. If it is, uniFY will start the main application and begin running automatically.

However, if this is first time uniFY is being run or the application was previously run in non-networked mode, or uniFY determines the previous adapter is found to be invalid for any reason, uniFY will first pop up a message asking if the user wishes to continue using the application in non-networked mode with limited functionality.
Selecting “Yes” to this message will open the main application in non-networked mode with all the networking features disabled. For full functionality, select “No”. At this point, the “Network Interface Selection” window will pop up.

Network Interface Selection

The drop-down list will contain a list of selectable network adapters. There will always be a “None” option at the top that allows the software to be used in non-networked mode should that be necessary.

*Note: unIFY must be used with a wired network card. If a USB to Ethernet adapter is used, the USB to Ethernet adapter must be attached to the PC otherwise unIFY may not start up correctly.

If the desired adapter is not found in the drop-down list, select the “None” option to get the main application window open. Once the issue with the network card has been diagnosed and fixed, use the “File” -> “Change Network” menu or the “Network Configuration” button on the button bar to re-open the “Network Interface Selection” window again to check if the correct adapter is now listed.

Once the desired interface is selected, click OK and if all is well, unIFY will then open the main application window.

*NOTE: Windows allows users to configure multiple IP addresses to a single network adapter. However, this feature is not supported by either the Audinate tools such as Dante™ Controller or unIFY Control Panel. Network adapters used to connect to a Dante™ network must either be set to get a dynamic IP address or have a single static IP address.

The network interface can be changed at any time while the application is running.

Main Application Window

The application is organized into the following sections:

- Menu and Tool bar
- Dante™ Device List
- Available Domains (Dante Domain Manager™)
- Application canvas
- Status Bar
At the top are the menus and a button toolbar. These allow access to various application functions. The toolbar has a default set of buttons but these may be supplemented by additional buttons as other application features are used. On the left side of the application window is the DDM server and device list. The available domains shows any available DDM servers and allows you to login. The device list shows a list of the detected devices and their current state. The main area of the application window is a canvas which will populate with various controls as the application is used. Finally across the bottom is a status bar which shows application status messages, errors and warnings.

**Dante Domain Manager™ Available Servers**

The Available Servers drop-down displays any Dante Domain Manager™ (DDM) servers on the network. When selected, a prompt will show on the main window to allow login to the domain.
Dante™ Device List

The Dante™ device list displays all Dante™ devices from any manufacturer that are detected on the active network interface. Devices are noted in different ways depending on their status as follows:

Red, strike-through - Device previously detected that is longer on the network or powered down or may have communication issues (see following paragraph).
Red, no strike-through - Device with a communication issue (see following paragraph).

White, Italicized - Non-Attero device or Attero device that do not have any configurable parameters such as the unD4O or unDUSB.

White, Bold, non-italicized - Attero device that is good to go and has configuration capabilities that unIFY can be used to change.

All Attero devices should appear in white. For Attero devices that appear in red that have not simply been disconnected from the network or powered down, it is likely that unIFY has a communication issue with that device.

If it is just a single device then a recent change of device name can cause this. A refresh of the device list should fix that (note a single refresh may not immediately work as it takes some time for unIFY to determine
the device with the old name is no longer available). Otherwise, the most likely cause of an issue is an IP address conflict where PC and device have IP addresses in different ranges.

However, if all Attero Tech devices in the list indicate red, that may be something more serious. The following issues are known to have caused problems:

- IP Address issue – The PC has an IP that not in the same IP range as all the devices
- 3rd Party Firewall / Anti-Virus / Internet Security applications blocking unFY access to/from the network
- Multicast filtering setup on network that prevents traffic from reaching the PC

The device list can be filtered using search box or the “Show Only” filter option. The “Show Only” filter will adjust the list to show only a specific type product. The search box attempts to match the text in the search box with any part of a devices name in the device list. The search box is case sensitive.

Dante™ & Parameter Locks

With V3.10 firmware, Dante™ devices have a facility that allows their Dante™ parameters to be locked to prevent changes (see Dante™ Controller help or the Audinate website for further details of this feature). The locked state can only be applied or removed using Dante™ Controller. Some Attero devices also now support a parameter lock to restrict access to the non-Dante™ device features like phantom power and gain. If a device has either its Dante™ lock or parameter lock enabled, a padlock icon will appear next to its name.

*Note: Any active locks on a device also impact what features such as Load/Save presets and firmware updates can be used on a device.

Channel Names

A device in the device list can be expanded to show or hide its Dante™ audio channels by either double-clicking on the device name or by clicking on the small “+” icon to the left of the device name. Any transmit channels the device has are shown prefixed with a [TX] and any receive channels are shown prefixed with an [RX]. The channel names can be collapsed again by either double-clicking on the device name or by clicking on the small “-“ icon to the left of the device name.

When the channels names are being shown, the application allows for the channels names to be changed. Right-clicking on a channel name will be show the “Rename” context menu.

*NOTE: Dante™ relies on the device name and channel names for audio routing. Changing the Dante™ channel names therefore may cause audio subscriptions to be lost and that audio will then cease to be transferred. Those subscriptions will need to be re-built using the new channel names for that particular audio to begin flowing again.

Device Context Menu

© QSC, LLC 2020
Right clicking on a device will open the device context menu.

“Status” shows the device status within the application. This field is typically used for diagnostic purposes. For Attero devices that are working correctly, the “Status” should show “Device Ready”.

The “Device Info” option has a sub-menu that shows specific information about the device. The Information shown includes the manufacturer, model name, control type (if known), MCU version (if known), and the device IP address. Not all fields may be populated depending on the devices “Status” and what information is available. Attero Tech devices should populate all fields.

Clicking the “Identify Device” option allow devices on the network to be visually located. This feature will flash the status LEDs. Power LED, or front panel display of the selected device for approximately five seconds to aid identification of the physical location of a device.

*NOTE: On Synapse devices, the front panel controls will not operate until the Identify timer is completed.

Clicking the “Configure Device” context menu item will open the associated configuration plug-in for the selected device. This option will only available on supported devices that have a suitable plug-in available. Access to a supported devices plug-in can also be gained by double-clicking on the device name in the device list too. Information about device specific plug-ins can be found in the Device Configuration article.

AES67 Device List

The AES67 device list displays all AES67-only devices from Attero Tech (other manufacturers AES67 devices will not be shown). Devices that appear in red indicate that there is a problem communicating with that device (it may mean the device is no longer on the network). Devices where communication with them has been successful will be shown in italicized white text. Attero Tech devices that have extended configuration capabilities will be shown in bold white text.

Once a device has been successful, double clicking on a device opens its configuration plug-in.

Device Context Menu

Right clicking on a device will open the device context menu.
“Status” shows the device status within the application. This field is typically used for diagnostic purposes. For Attero devices that are working correctly, the “Status” should show “Device Ready”.

The “Device Info” option is a sub-menu that shows specific information about the device. The information shown includes the manufacturer, model name various firmware version details, and the device IP and MAC address. When correctly connected, Attero Tech devices should populate all fields. However, not all fields may be populated depending on the devices “Status” and what information is available.

Clicking the “Identify Device” option allow devices on the network to be visually located. This feature will flash the status LEDs, Power LED, or front panel display of the selected device for approximately five seconds to aid identification of the physical location of a device.

*NOTE: On Synapse devices, the front panel controls will not operate until the Identify timer is completed.

Clicking the “Configure Device” context menu item will open the associated configuration plug-in for the selected device. This option will only available on supported devices that have a suitable plug-in available. Information about device specific plug-ins can be found in the Device Configuration article onward.

AES67 Stream List

The AES67 stream list displays all AES67 streams that unIFY detects. It will includes streams from both Attero Tech devices and devices from other manufacturers. Each stream may be expanded to show the individual channels that stream contains.

Streams that appear in red indicate that the stream was previously detected by unIFY but currently that stream is no longer being advertised. This could be because the stream was turned off on the transmit device, has been reconfigured to something different, or the unit that was transmitting that stream is no longer on the network or is powered off.

The stream list is used to route audio to Attero Tech devices when they are being configured (the plug-in for device that will receive the audio needs to be opened on the “Stream Configuration” tab). Audio channels may be assigned by clicking and dragging a specific channel from the desired transmit stream and dropping it onto a specific channel of receiver setup in the desired devices plug-in. Doing so will populate both the assigned stream and channel number fields for that output channel. The unIFY application will not allow allocation of a complete stream (by clicking and dragging a device name) in one go. It must be done channel by channel.

© QSC, LLC 2020
The stream also has a diagnostic function. If an AES67 devices plug-in is open, unIFY will check to see if the configuration of the stream the device is receiving differs from that in the stream list. If all is ok, all the streams in the stream list the device is correctly receiving will be highlighted in green. However, if unIFY detects a problem such as the IP address of the stream has now changed, the stream will instead be highlighted in yellow. In such cases, the RX status indicator in the plug-in will also indicate a problem receiving the stream too.

**Control Devices**

The Control device list displays all control devices from Attero Tech. This is currently only the Axon C1 but others may be added in the future. Devices that appear in red indicate that there is a problem communicating with that device (it may mean the device is no longer on the network). Devices where communication with them has been successful will be shown in italicized white text. Attero Tech devices that have extended configuration capabilities will be shown in bold white text.

Once a device has been successful, double clicking on a device opens its configuration plug-in.

**Compromised Devices**

In order to communicate with devices over the network, the IP of the PC must be in the same range as the IP of the device. For AES67 and control devices, unIFY can detect if there is an IP address mismatch. When it does, unIFY will display a "Compromised Device List" button.

Clicking on the button brings up the "Compromised Device List" window. This list shows the AES67 and Control devices that unIFY has detected, their MAC address and their current IP addresses.
Compromised Device List

Active Network: 192.168.78.247

*These device(s) do not belong to your active subnet

<table>
<thead>
<tr>
<th>New Column</th>
<th>MAC Address</th>
<th>IP Address</th>
</tr>
</thead>
<tbody>
<tr>
<td>AxonC1-f0f53</td>
<td>00:1c:e2:f0:0f:53</td>
<td>169.254.84.15</td>
</tr>
<tr>
<td>AxonC1-f0f37</td>
<td>00:1c:e2:f0:0f:37</td>
<td>169.254.56.15</td>
</tr>
</tbody>
</table>

In order to communicate with these devices, change the IP address of the NIC that unIFY is using to communicate with the network to something that is in the same range of the device you want to communicate with.

*Note: Dante devices with incompatible IP’s will not appear in this list. Dante devices with incompatible IP’s will show in red on the Dante device list.

Menu & Tool Bar Functions

Refresh Device List
This feature can be accessed from the toolbar button or an option in the “File” menu. It will refresh the current Dante™ device list shown on the main screen of the application. The discovery process will only detect devices that are connected to the actively selected network adapter within the application.

*Note: If the application is detecting devices but all of the devices are shown in red, that indicates a network conflict and is likely the result of mismatched IP address configuration between the actively selected network interface card and the target Dante™ devices.

Network Interface
Allows the user to select a different network interface to use with the application.

Dante™ Controller

© QSC, LLC 2020
unIFY Control Panel provides a configuration tool for the device specific parameters of Attero Tech devices. For general device routing or Dante™ network configuration, Attero Tech recommends the use of Dante™ Controller software from Audinate. To simplify system configuration, Dante™ Controller can be launched directly from the unIFY application by clicking the Dante™ Controller button or the Dante™ Controller option from the File menu.

If this option is being used for the first time, it will ask for the location of the installed Dante™ Controller software. If the Dante™ Controller application is not installed on your computer, you may download a copy at the following link: https://www.audinate.com/products/software/dante-controller

Once the program location has been identified, Dante™ Controller will open. Subsequent uses will simply open the Dante™ Controller application.

Help
The help menu provides access to information about the application version, application plugin-in versions, and also the application help. The application version and plug-in version information can only be accessed via the Help menu while the application help can be accessed via the Help menu or the Help button on the toolbar.

*Note: The application help is provided in the form of a PDF and a suitable reader will be needed for the help to be viewed.

Multi-Device Preset Load

In order to simplify device configuration in systems deploying a large number of common Attero Tech devices, the Multi-Device Preset Load tool allows the user to select a device preset that can be applied to multiple devices in one update process. This is accessed through an option in the Tools menu.

When the Multi-Device Preset Load menu item is selected, a pop-up window appears asking for the location of a .CFG file. All .CFG files are generated when executing the Save Presets to File functionality for a device. Once the file is loaded, the main canvas will show the multi-device preset load plug-in. The application will identify all compatible devices which can accept the preset file. These devices will be shown in the list along with a progress bar for the preset update progress.

*Note: Any devices that have their parameter lock active will have a padlock icon and the progress bar replaced with text warning the device is locked.

Select one or more devices by clicking on the checkbox for each desired device. Alternatively, all devices can be selected for preset loading by pressing the Select All button. Once the desired device selections have been made, press the Start button to initiate the preset loading process. If at any time the preset loading process needs to be stopped or exited, press the Close button.

Smart Firmware Updater

For unIFY v2.3 onwards, a feature was integrated that adds support for Attero Tech device firmware updates. This functionality is accessed by selecting and launching the Smart Firmware Update from the Tools menu.
To use the updater, first click on the Select File button. This will open a file explorer window for the selection of the desired firmware package. The smart firmware updater utilizes .SFU firmware packages. These files are available for download on the QSC website.

Once the desired file has been selected, the application will search for devices that match the selected firmware update package. The application will also determine the relevant features that require updates on each device.

The discovered device list shows the following information about the device.

- Device Name
- Product Version
- Device Mode – This control allows selection between -B/-C and -U firmware option support for proper integration with the target DSP and/or control system used in the product installation
- Status - Shows the number of required steps for the update based on the current state of the device
- Progress - The top progress bar shows the progress for the current step in the update

*Note: If either Dante™ lock or the parameter lock are active, the device will show up with a padlock next to it and the progress bar will be replaced by text indicating the device has an active lock. No updates will be possible in this device until the lock is removed.

To initiate an update, check the device or devices in the list with their associated checkbox and click on the Start button. The smart firmware updater will determine the appropriate portions of the device firmware
that require updates. To override this functionality and force a complete update, select the Force All Updates checkbox.

The update process can be stopped at any time by pressing the Cancel button, however, in order to prevent device lockups the updater will continue until it is safe to cancel the overall update operation.

If a device fails during the update process it will be shown in red after updates to all other selected devices are complete.